BGforge translation system. Language-specific forums for translators are inside.
charlesdexterward
Posts: 23
Joined: Thu Jul 02, 2020 4:24 pm

Upload of po-file fails

Post by charlesdexterward » Fri Jul 03, 2020 3:47 pm

I've dowloaded the german UP po (fallout-up-de.po) to edit it with poedit and make use of it's more convenient search/replace functionality. After I was done, I've tried to upload it again and got some error screen (something with cloudflare, I get this quite often using this site). I've tried again and now it says "File content merge failed: The file lock '/var/www/html/weblate/data/vcs/fallout/up.lock' could not be acquired.".

I assume you can remove the lock, but I'm afraid this will happen again.
The file is about 8megs. Could it be too much for the server or sth?

User avatar
Magus
Site Admin
Posts: 244
Joined: Mon Nov 21, 2016 9:13 am
Contact:

Re: Upload of po-file fails

Post by Magus » Fri Jul 03, 2020 3:50 pm

  1. Please attach the file.
  2. How many times did you try?
  3. What else you get "quite often"? A screenshot of that?
  4. The system has built-in search and replace (just in case you didn't notice).
Please do not PM or email me about my mods and projects. Use forums. Also, see our talk channels.

charlesdexterward
Posts: 23
Joined: Thu Jul 02, 2020 4:24 pm

Re: Upload of po-file fails

Post by charlesdexterward » Fri Jul 03, 2020 4:04 pm

1. See attachment. I had to zip it so it doesn't get denied by the forum software.
2. 4 times I think. The first time failed after some time with error screen (cloudflare or sth)
3. I get this sometimes after saving a translated string. I don't now the exact message, since i reload the page and then it works most of the time. I'll make a screenshot next time I see it.
4. I know, but it offers only a search and replace for the whole po. I need a search and replace tool with confirmation on every occurance. It's just too dangerous otherwise.
Attachments
fallout-up-de.po.zip
(2.34 MiB) Downloaded 11 times

User avatar
Magus
Site Admin
Posts: 244
Joined: Mon Nov 21, 2016 9:13 am
Contact:

Re: Upload of po-file fails

Post by Magus » Fri Jul 03, 2020 4:35 pm

I can reproduce. Can't say for sure yet, but it may have to do with the fact that lock is per component (=UP, for example), and it keeps for some time, so if anyone is translating any the component into any other language, it'll fail to merge.

However the built-in is with confirmation on every occurance, have you tried it?
Captura de pantalla de 2020-07-03 23-33-35.png

Don't hesitate to report any other issues, preferably in a separate topic each, with screenshots and steps to reproduce.
Please do not PM or email me about my mods and projects. Use forums. Also, see our talk channels.

charlesdexterward
Posts: 23
Joined: Thu Jul 02, 2020 4:24 pm

Re: Upload of po-file fails

Post by charlesdexterward » Fri Jul 03, 2020 5:17 pm

So I've tried the upload again and got the message you see in the attachement.

About the replace option: I see. I got the impression that it replaces everything instantly if you click "process"; the page is a bit misleading in that regard.
Nevertheless, it would be a real bummer if the upload doesn't work. Because offline translation with po files can still be much faster for some tasks, and I already put quite some effort into this file.
Attachments
screenshot.jpg

User avatar
Magus
Site Admin
Posts: 244
Joined: Mon Nov 21, 2016 9:13 am
Contact:

Re: Upload of po-file fails

Post by Magus » Fri Jul 03, 2020 5:27 pm

I understand that offline could be more convenient in some cases. I'll continue looking into it, but it could take a few days.
Please do not PM or email me about my mods and projects. Use forums. Also, see our talk channels.

charlesdexterward
Posts: 23
Joined: Thu Jul 02, 2020 4:24 pm

Re: Upload of po-file fails

Post by charlesdexterward » Sat Jul 04, 2020 12:48 pm

So in the meantime I'm continuing my work offline in the hope that the issue gets resolved soon.

Have you tried to upload my attached file from your side?

User avatar
Magus
Site Admin
Posts: 244
Joined: Mon Nov 21, 2016 9:13 am
Contact:

Re: Upload of po-file fails

Post by Magus » Sat Jul 04, 2020 12:55 pm

charlesdexterward wrote:
Sat Jul 04, 2020 12:48 pm
Have you tried to upload my attached file from your side?
Yes, reproduce is the first thing to do in troubleshooting.
charlesdexterward wrote:
Sat Jul 04, 2020 12:48 pm
So in the meantime I'm continuing my work offline in the hope that the issue gets resolved soon.
As you wish, but I can't promise anything yet. In general, it's better to keep the work online though, to avoid merge conflicts when multiple people are translating.
Please do not PM or email me about my mods and projects. Use forums. Also, see our talk channels.

egornovivan
Posts: 5
Joined: Fri Jul 03, 2020 4:44 pm

Re: Upload of po-file fails

Post by egornovivan » Sun Jul 05, 2020 11:34 pm

This problem only with po files or xlf, tmx are not loaded too?


Yep. How to reproduce? Just download xliff and upload back.
[img]https://sun1-90.userapi.com/bPn1cYD6hJd ... BIzxuM.jpg[/img]

can try to split the file into several parts, maybe then it will work out.

User avatar
Magus
Site Admin
Posts: 244
Joined: Mon Nov 21, 2016 9:13 am
Contact:

Re: Upload of po-file fails

Post by Magus » Mon Jul 06, 2020 1:33 pm

That is not surprising.
Please do not PM or email me about my mods and projects. Use forums. Also, see our talk channels.

Post Reply